Continuous replication automatically synchronizes data between source and target systems in real time, ensuring that changes made in the source are immediately reflected in the target. Use the replication project list to monitor pipeline health and manage projects.
Note: You must have the Replication Designer role to configure and manage
replication pipelines. A workspace manager can assign the role from the Manage User page.
Replication project list
The continuous replication page lists all configured replication projects. For each project you can see:
- Health: Overall status of the replication pipeline.
- Project: Name of the replication project.
- Engine Processes: Status of processes running on all runtime
servers in the project.
- Partial: One or more engine processes are stopped.
- Stopped: Kernel processes on the source server are not running. Committed but undeployed projects also show as stopped.
- In progress: A deployment change is actively taking place.
Note: This status takes precedence over others, except Action Required, until the process completes.
- Unknown: Temporary communication issues between components.
- Ok: All server kernel processes are operational.
- Ignored: The project is marked as ignored and not actively monitored.
- Replication: Status of replication processes across all runtime
servers in the project.
- Action Required: Errors have occurred requiring immediate
attention.
Note: Email notifications are sent to replication designers when the status changes to Action Required.
- Partial: One or more replication processes are stopped.
- Stopped: Replication processes are not running.
- In progress: Configuration changes are being applied.
Note: This status overrides all others except Action Required until changes are finalized.
- Attention: Copying is ongoing but not all tables are being replicated (copy-type pipelines only).
- Unknown: Temporary communication issues.
- Ok: All replication processes are operational.
- Ignored: The project is marked as ignored.
- Action Required: Errors have occurred requiring immediate
attention.
- Capture: Status of table capturing across all data connections.
- In progress: Configuration changes are being applied to table capturing.
- Unknown: The project is stopped (except when source connections are exclusively Oracle type).
- Attention: Not all selected tables are enabled for capture.
- Disabled: All selected tables have capture disabled.
- Ignored: The project is marked as ignored.
- Log Reader: Status of the log reader component.
- Action Required: Failure or timeout when starting the log
reader. Note: Email notifications are sent to replication designers when this status occurs.
- Stopped: The log reader has stopped capturing changes.
- In progress: Configuration changes are being made active.
Note: This overrides all other statuses except Action Required.
- Unknown: Temporary communication issue or runtime server processes are stopped.
- Ok: The log reader is active and capturing changes.
- Ignored: The project is marked as ignored. Note: Imported models that are ignored can be started using MonCon, which replaces the ignored status with the actual project status.
- Action Required: Failure or timeout when starting the log
reader.
- Backlog Rows: Number of rows queued on the source server pending replication to the target.
- Longest Current Latency: The longest time from data capture on the source to application on the target.
- Last Updated: Timestamp of the last portlet update.
Note: The portlet refreshes every 5 seconds to reflect the most current pipeline state.